Troubleshooting "DataSource matching query does not exist" Error

Last updated: April 1, 2025

If you encounter a "DataSource matching query does not exist" error when viewing dashboards, this means that Explo is not able to find the correct database to connect to.

Common Causes

  • Recent migration to a new database connector

  • Removed or reconfigured data sources

Resolution Steps

  1. Verify your data source is properly configured and connected in your Explo settings

  2. Go to the customer in the customer tab, edit, and resave that customer. To force a resave, you can add a space to the end of the customer name or similar, save, and then revert the update.

  3. If the error persists after resaving the customer group or you have multiple customers affected, contact Explo support as the issue may require backend resolution

If this error appears after migrating to a new connector or existing data sources are deleted, it may indicate that old data source references need to be updated in our system. Contact support for assistance with resolving these legacy connections.